Luma Health Holiday Hours 2020
Incident Report for Luma Health
Resolved
Luma Health is now operating on normal business hours. Hope all our partners had a wonderful holiday season and welcome to 2021!
Posted Jan 04, 2021 - 08:16 PST
Monitoring
We will be operating on holiday hours December 23rd 2020 to January 1st 2021; please contact us at support@lumahealth.io. You may experience a delay in response. We will be back in the office for normal business hours on Monday January 4th. Happy Holidays!
Posted Dec 21, 2020 - 17:03 PST
This incident affected: Luma Health Web (next.lumahealth.io).