Thanksgiving Holiday
Incident Report for Luma Health
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 06:33 PST
Investigating
We will have limited support hours Nov. 26th and Nov. 27th; you may experience a delay in response. Regular business hours will resume Monday Nov. 30th. Happy Thanksgiving!
Posted Nov 25, 2020 - 17:28 PST