Slowness across Luma Platform

Incident Report for Luma Health

Resolved

This incident has been resolved. The slowness affecting Luma services has been fully addressed and performance has returned to normal levels.

Earlier today, a large-scale data processing operation triggered an unexpected spike in our infrastructure, which led to the slowness some users experienced across Luma services. Our Engineering team identified the root cause, deployed a fix, and is continuing to make improvements to prevent this from happening again.
Posted Jun 11, 2026 - 12:58 PDT

Monitoring

A fix has been deployed and we are monitoring the results. Luma services are recovering and performance is returning to normal levels.
Posted Jun 11, 2026 - 11:28 PDT

Update

We have identified the issue impacting Luma services performance. Our Engineering team is still working on a fix and is progressing toward a complete resolution.
Posted Jun 11, 2026 - 11:02 PDT

Identified

We have identified the issue causing the slowness in Luma services. Our Engineering team is actively working on a fix and making progress toward full resolution.
Posted Jun 11, 2026 - 10:01 PDT

Investigating

We are currently investigating reports of slowness in the Luma Platform. Our team is actively working to identify the root cause.
Posted Jun 11, 2026 - 09:31 PDT
This incident affected: Luma Health Web (next.lumahealth.io).