This incident has been resolved. All Luma systems are now operating normally.
The performance degradation was caused by an unexpectedly high load on our platform, which impacted response times across all systems. Our engineering team responded quickly, identified the root cause, and implemented the necessary changes to stabilize the environment.
We apologize for any disruption this may have caused to your workflows and thank you for your patience throughout this incident.
Posted Jun 17, 2026 - 13:49 PDT
Update
Our engineering team continues to monitor the Luma Platform following the fix implemented earlier. Performance metrics are trending in the right direction and systems are stabilizing.
Posted Jun 17, 2026 - 12:43 PDT
Monitoring
We have identified the root cause of the slow performance affecting the Luma Platform and have implemented a fix. Our engineering team is actively monitoring the systems to confirm full recovery.
Posted Jun 17, 2026 - 11:53 PDT
Investigating
We are currently investigating reports of slow performance affecting the Luma Platform.
Our engineering team has been engaged and is actively investigating the root cause. Users may experience slower than normal load times and delayed responses during this time.
Posted Jun 17, 2026 - 11:36 PDT
This incident affected: Luma Health Web (next.lumahealth.io).