This incident has been resolved. Forms, Checklists, and the Clinic app are now loading normally. Our Engineering team confirmed the fix and will continue to monitor the situation to ensure stability.
We apologize for any inconvenience this may have caused and thank you for your patience.
Posted Sep 18, 2026 - 12:09 PDT
Update
We are currently experiencing intermittent loading issues affecting Forms, Checklists, and the Clinic app. Our Engineering team has identified the impact and is actively working to resolve it. Other Luma services are not affected at this time.
We will provide an update as more information becomes available.
Posted Sep 18, 2026 - 11:48 PDT
Investigating
We are currently investigating reports of slow performance affecting Luma services. Our team is actively working to identify the root cause. We will provide an update as soon as more information is available.
Posted Sep 18, 2026 - 11:26 PDT
This incident affected: Luma Health Web (next.lumahealth.io).