System Delays

Incident Report for Luma Health

Resolved

This incident has been resolved.

We saw an increase in load on our internal database which caused UI latency and a brief delay in reminder messages. Latency was at its worst from 9am-9:25am pst. We have adjusted internal scaling to better handle these spikes.
Posted Jul 11, 2025 - 10:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2025 - 09:31 PDT

Update

We are continuing to investigate this issue.
Posted Jul 11, 2025 - 09:10 PDT

Investigating

We're experiencing system delays and are currently looking into the issue. We will post a new update within the next 30 minutes.
Posted Jul 11, 2025 - 08:58 PDT
This incident affected: Luma Health Web (next.lumahealth.io), Luma Health API, Communication Services, and EHR/PM Integration System.