System Delays

Incident Report for Luma Health

Resolved

This incident has been resolved.
Posted May 06, 2025 - 16:52 PDT

Update

We were able to stabilize the other impacted services, but we're still seeing delays in messaging, and our team is actively working on a fix for it.
Posted May 06, 2025 - 12:38 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 06, 2025 - 11:59 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 06, 2025 - 11:40 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2025 - 11:26 PDT

Investigating

We're experiencing system delays and are currently looking into the issue. We will post a new update within the next 15 minutes.
Posted May 06, 2025 - 11:10 PDT
This incident affected: Luma Health API, Communication Services, EHR/PM Integration System, and Auth0 User Authentication (SSO).