The issue impacting system performance has been addressed, and all affected services are now operating normally. We are continuing to monitor the platform closely to ensure ongoing stability.
Posted Jun 18, 2025 - 14:30 PDT
Identified
We’ve identified the issue causing delays in messaging and access to next.lumahealth.io. Our team is actively working to mitigate the impact and restore full service functionality.
We’ll continue to provide updates as we make progress.
Posted Jun 18, 2025 - 13:08 PDT
Update
Update – We’ve identified elevated connection spikes and operation queues impacting performance. Mitigation efforts are underway, and we’re continuing to monitor system health closely. We will provide the next update within 30 minutes or as soon as more information becomes available.
Posted Jun 18, 2025 - 12:24 PDT
Update
The investigation into the delays is still in progress. We will post the next update within 1 hour or as soon as we have additional information.
Posted Jun 18, 2025 - 12:00 PDT
Update
We're continuing to investigate the delays. We will post a new update within the next 30 minutes.
Posted Jun 18, 2025 - 11:30 PDT
Investigating
We're experiencing system delays and are currently looking into the issue. We will post a new update within the next 30 minutes.
Posted Jun 18, 2025 - 11:00 PDT
This incident affected: Communication Services and EHR/PM Integration System.