Cloudflare Global Network issues

Incident Report for Luma Health

Resolved

Cloudflare states that this incident has been resolved. For more information: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:56 PST

Update

We will keep monitoring their recovery process. We appreciate your patience, and will keep you updated as more information becomes available.

For more Information: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 08:08 PST

Monitoring

A fix has been implement by the Cloudflare team and they believe it resolved the global incident, we will keep monitoring their recovery process. We appreciate your patience, and will keep you updated as more information becomes available.
Posted Nov 18, 2025 - 06:52 PST

Update

Our team is still actively monitoring the situation and will continue to follow Cloudflare's recovery process.

We appreciate your patience, and will keep you updated as more information becomes available.

For more Information: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 06:20 PST

Investigating

We were notified by Cloudflare that they're experiencing Global Network issues that may impact Luma Health services. Our team is actively monitoring the situation and will continue to follow Cloudflare's recovery process.

We appreciate your patience, and will keep you updated as more information becomes available.

For more Information: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 05:39 PST
This incident affected: Luma Health Web (next.lumahealth.io), Luma Health API, Communication Services, EHR/PM Integration System, Luma Health Patient Web (patient.lumahealth.io), and Reporting and Datawarehouse.