We are seeing Issues with accessing next.lumahealth.io

Incident Report for Luma Health

Resolved

This incident has been resolved.
Posted Aug 08, 2022 - 20:09 PDT

Investigating

We are currently investigating this issue.
Posted Aug 08, 2022 - 20:03 PDT
This incident affected: Luma Health Web (next.lumahealth.io).