Activity Page issues on next.lumahealth.io
Incident Report for Luma Health
Resolved
This incident has been resolved.
Posted May 15, 2020 - 06:10 PDT
Investigating
We're experiencing an elevated level of errors on Luma Health and are currently looking into the issue. This is currently causing an inability for certain users with activity feed
Posted May 15, 2020 - 05:56 PDT
This incident affected: Luma Health Web (next.lumahealth.io).