Slowness on Schedule View

Incident Report for Luma Health

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 08:48 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 08:33 PST

Update

We are continuing to investigate this issue.
Posted Mar 04, 2026 - 08:07 PST

Investigating

We're experiencing slowness on the Schedule View and are currently looking into the issue. This is currently causing an inability for certain users to access https://next.lumahealth.io/schedule Patient communication is not impacted at this time.
Posted Mar 04, 2026 - 07:41 PST
This incident affected: Luma Health Web (next.lumahealth.io).